Adobe Reader Update Failure

Idiotic Adobe Reader (aka Adobe Acrobat).

When in Google Chrome browsing a pdf file, Chrome tells me: “Parts of this PDF document could not be displayed. Open in Adobe Reader?”. So i clicked Yes. Then, Chrome tells me: “Adobe Reader is out of date and may be insecure”, with a option to update. That's a bit strange, because i thought i have it up-to-date. So, i manually opened Adobe Reader, then clicked on the “Check for Update…” under the Help menu. It says: “No updates available”. I then checked version, it's “9.4.2”. Then i went back to Chrome and get the update, the download is “Adobe Reader X (10.0.1)”. Fucking idiotic Adobe Reader.

See also: The Complexity & Tedium of Software Engineering.

and Google Chrome is really fantastic. See: Google Chrome & Browser War II.

Popular posts from this blog

11 Years of Writing About Emacs

does md5 creates more randomness?

Google Code shutting down, future of ErgoEmacs